Dreams Bugs šŸœ

With such a huge suite of creative tools, you may encounter occasional bugs in Dreams. Itā€™s really helpful for us to hear about them! If you discover an issue in Dreams, please check to see if anyone else has reported the issue before and if someone has, comment on it with your experiences. If not, post a new bug report here!

Hereā€™s some top tips to help us track down your bug as quickly as possible:

ā€¢ Give us a brief, clear summary of the bug. If necessary let us know what you think should be happening that isnā€™t.
ā€¢ Let us know the exact steps we need to follow to recreate your bug. For example -
ā€œLoad game > go to create mode > search for banana > stamp ā€œsuper cool bananaā€ > the banana didnā€™t load!"
ā€¢ If possible it really helps if you can include a screenshot or video of the problem.
ā€¢ Let us know the release version of the game ā€“ you can find this by having the Dreams icon highlighted on the Playstation homescreen, pressing ā€œoptionsā€ and then ā€œinformationā€. The bit we want is the Version number!

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Animating sun direction is now broken

    I had a gadget called "Day Night cycle V2" where I carefully synchronise a Syn&Sky gadget with a rotating physical Sun and Moon.
    It worked well, so that you can have a physical Sun, but synchronised water reflections.
    Now if I edit my keyframes even slightly, it totally breaks the synchronisation.
    Here is a video hightlighting the issue:
    https://www.youtube.com/watch?v=Nfpzo0HiCSQ
    The element is here:
    https://indreams.me/element/okgSmsdsaYq

    Regards!

    5 votes
    Sign in
    (thinkingā€¦)
    Sign in with: Sony Entertainment Network
    Signed in as (Sign out)

    Weā€™ll send you updates on this idea

    acknowledged  ·  6 comments  ·  Animation  ·  Flag idea as inappropriateā€¦  ·  Admin →
  2. 1st person camera is not resetting after using a camera gadget.

    I have a first person puppet. I use a timeline to do a flyover of my scene. After the camera timeline ends I would like it to go BACK into first person but it seems to always put the camera inside my character.

    2 votes
    Sign in
    (thinkingā€¦)
    Sign in with: Sony Entertainment Network
    Signed in as (Sign out)

    Weā€™ll send you updates on this idea

    acknowledged  ·  4 comments  ·  Animation  ·  Flag idea as inappropriateā€¦  ·  Admin →
  3. Keep changes does not work when animating puppet limbs.

    The limbs stay in position only while the keyframe is powered on, even though it is using "Keep Changes." Procedural animations have been turned off.

    2 votes
    Sign in
    (thinkingā€¦)
    Sign in with: Sony Entertainment Network
    Signed in as (Sign out)

    Weā€™ll send you updates on this idea

    acknowledged  ·  3 comments  ·  Animation  ·  Flag idea as inappropriateā€¦  ·  Admin →
  4. Record Possession breaks jumping animation after 2 minutes

    After using the Record Possession for like two minutes it jumps, kinda resets itself and breaks the jumping animation:
    https://twitter.com/Elca_Gaming/status/1227710129723858950?s=19

    1 vote
    Sign in
    (thinkingā€¦)
    Sign in with: Sony Entertainment Network
    Signed in as (Sign out)

    Weā€™ll send you updates on this idea

    acknowledged  ·  4 comments  ·  Animation  ·  Flag idea as inappropriateā€¦  ·  Admin →
  5. Action recorder and trigger zone only works once

    I've tried to make two very simple levels so far but keep getting hung up on this issue.

    I want platforms that play their recorded animation when a possessed puppet enters the trigger zone. This always works as intended on the first platform but any time I try to add another one it takes forever to trigger and that's if the platform comes at all. All tweak options are matched with the platform that works as intended and I've tried all other options on two different levels.

    If this isn't a bug and I'm just missing something I apologise butā€¦

    1 vote
    Sign in
    (thinkingā€¦)
    Sign in with: Sony Entertainment Network
    Signed in as (Sign out)

    Weā€™ll send you updates on this idea

    acknowledged  ·  3 comments  ·  Animation  ·  Flag idea as inappropriateā€¦  ·  Admin →
  6. Keyframe change not reverting to default after finished recording.

    I've tested this on default puppet. I'm not sure if this is only with the tweaks im using or if theres a larger keyframe change issue.

    To replicate:
    - Stamp in default puppet.
    - Open tweak menu at labels
    - add a keyframe
    - Record switching on two or more labels.
    - Exit out of recording.

    Everything past the first change will still be applied to the puppet.

    Edit; This looks like a visual bug only - when you enter play mode it reverts.

    1 vote
    Sign in
    (thinkingā€¦)
    Sign in with: Sony Entertainment Network
    Signed in as (Sign out)

    Weā€™ll send you updates on this idea

    acknowledged  ·  2 comments  ·  Animation  ·  Flag idea as inappropriateā€¦  ·  Admin →
  7. Button doesnā€™t trigger cutscene in cinematic sound design tutorial

    Once in the ā€˜Cinematic Sound Designā€™ tutorial, complete steps all the way up to finalising the sound timeline for the double rising platform cutscene.

    Once you go to trigger said cutscene in play mode, nothing happens upon pressing the button. Almost as if the wiring inside the button hadnā€™t reached the animation of the platforms?

    1 vote
    Sign in
    (thinkingā€¦)
    Sign in with: Sony Entertainment Network
    Signed in as (Sign out)

    Weā€™ll send you updates on this idea

    acknowledged  ·  1 comment  ·  Animation  ·  Flag idea as inappropriateā€¦  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base